Email Search Outage
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted 4 months ago. Jun 24, 2019 - 14:58 CEST
Investigating
We are currently investigating the issue.
Posted 4 months ago. Jun 24, 2019 - 14:13 CEST
This incident affected: Extension.