Extension Searches affected on Sales Navigator
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted 7 months ago. Mar 22, 2019 - 16:48 CET
Investigating
We are currently investigating the issue.
Posted 7 months ago. Mar 21, 2019 - 16:00 CET
This incident affected: Extension.