Major Outage
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted over 1 year ago. Jul 09, 2018 - 11:26 CEST
Investigating
We are currently investigating the issue.
Posted over 1 year ago. Jul 09, 2018 - 11:08 CEST
This incident affected: Web application, Extension, and API.