Partial outage
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted 12 months ago. Feb 28, 2018 - 09:55 CET
Investigating
We are currently investigating this issue.
Posted 12 months ago. Feb 27, 2018 - 15:56 CET