Major Outage
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted 10 months ago. Jul 13, 2017 - 20:44 CEST
Identified
The issue has been identified and a fix is being implemented.
Posted 10 months ago. Jul 13, 2017 - 15:10 CEST
Investigating
We’re experiencing some technical difficulties.
We’re doing our best to bring things back to normal as soon as possible.
Unfortunately, we cannot say precisely when.

We’re really sorry, check back in a few hours!
Posted 10 months ago. Jul 13, 2017 - 15:09 CEST