Partial Outage of the Prospect.io Google Chrome extension
Incident Report for Prospect.io
Resolved
No more issue was reported by users having a Sales Navigator LinkedIn Premium account since version 2.3.62 was released on Friday 26th of January.

This incident is therefore considered as closed.

Don't hesitate to reach us at support@prospect.io if you experience anything abnormal.
Posted about 1 year ago. Jan 31, 2018 - 16:23 CET
Monitoring
We released a new version of the extension today around 3 P.M UTC+1 in order to fix some spotted issues for Sales Navigator LinkedIn Premium users.

Some issues may not have been spotted yet, we are still monitoring the situation.

Please re-install the extension. To do so, click on the extension icon in Chrome and click on "Remove from Chrome".
You'll then be redirected to a page where you can re-install the extension.

Then try it again on LinkedIn and let us know if you experienced anything unusual and provide as much information as possible (url, screenshot, errors in the console).
Posted about 1 year ago. Jan 26, 2018 - 16:59 CET
Identified
Some Sales Navigator Premium LinkedIn users are experiencing issues with the Google Chrome extension when trying to find an email address on LinkedIn, either on a profile or in a search, seeing an infinite loader.

We spotted the plausible origin of this and are currently working on a fix.

We will keep posted.
Posted about 1 year ago. Jan 26, 2018 - 14:09 CET