Major Outage
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted almost 2 years ago. Jun 30, 2016 - 19:34 CEST
Identified
We're currently experiencing an major outage on our entire platform.
Posted almost 2 years ago. Jun 30, 2016 - 17:50 CEST