Partial Outage on Google Chrome extension
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted about 1 year ago. Jun 29, 2016 - 12:10 CEST
Identified
We're experiencing issues with the Google Chrome extension and are currently looking into it. We'll update the status of this incident as soon as we have fixed this issue.
Posted about 1 year ago. Jun 29, 2016 - 08:11 CEST