Degraded Performance in Chrome Extension
Incident Report for Prospect.io
Resolved
This incident has been resolved.
Posted 14 days ago. Sep 07, 2017 - 15:59 CEST
Identified
We are experiencing a lot of "Email not found" results in the extension. Our engineers are fixing the issue.

Sorry for the inconvenience.
Posted 14 days ago. Sep 07, 2017 - 12:11 CEST